• Check TWRP-Version if ROM-Inst. not flawless!
Page 1 of 1

Check TWRP-Version if ROM-Inst. not flawless!

Posted: 12 Nov 2017, 21:20
by MLandsp
Thought as a hint for Globe-ROM Users-
might be good if i share my experience after "Updating" my cofface-TWRP 3.0.something- the one you must blindly change to english ;)
Installed the "official TWRP App" and installed a newer Version, 3.1.something.
The next Update- as always only wiped /system and the caches- made small problem, only the base ROM was installed, no beauty mod, no center clock, no nothing- last time (today) it not even had root... so i started to find the problem.
TWRP was not my first candidate- but i remembered something is going wrong since i've updated.
Luckily i found over XDA-Developers a link to a TWRP 3.1.0 from cofface...
Link: ... N6eTA/view
since i've installed this- exacly said the 3.1.0-3 version- everything is running 100% ok again!

Maybe it helps someone...

PS: Phone is the redmi 4x santoni "Pro" (means global version)
and to introduce myself a bit: located in germany/bavaria, 25 Years PC-hobbyist, advanced Linux-beginner, married with children-
and my wife wants a Xiaomi-Phone too now ;)
...took some time, but now she has seen how "premium" her S6edge is :D
So i know the present for her on Xmas... 8-)

Re: Check TWRP-Version if ROM-Inst. not flawless!

Posted: 12 Nov 2017, 21:29
by dr4kendroid
Thanks for sharing your experience. If you have problems in future, just upload the globeROM logfile and we will help you :)

Re: Check TWRP-Version if ROM-Inst. not flawless!

Posted: 22 Jan 2018, 20:09
by MLandsp
Have to add one more experience-
still unclear to me why, but same thing happened again to me, only "base System" was installed.
Seemed as would /system be no more RW mounted after base system was installed.
So i tried the official TWRP, yes, the one with the encrypted /data thing...
made /dataBackup with old TWRP, updated to official from
formattet /data, restored Backup, formatted /system (and caches, of course) and voila:
works like a charme, with every selected and deselected feature, without any data lost!

Just as a hint, maybe it helps people who are not sure about the /data thing with some TWRP-Versions.
If you Backup and restore it, there's no Problem and no data lost :)

I'm still not sure what's sometimes making problems, but i think, not the mi-globe Roms are the reason.
If there was something faulty, it would make problems with every TWRP Version.
Maybe it has something to with the encrypted /data part, because since reformatting everithing works excellent.

Again: try to update your TWRP if there's something not as it should be, but if everything works, think about it twice ^^
(you know, never change a runnung system- or make at least a backup first :D )