Can't setup Gear S3 Classic

Post your Bugs, Requests and Support Questions about MiUI globeROM and Mods here.

Moderator: dr4kendroid

User avatar
0908727527
New Member
New Member
Posts: 3
Joined: 08 Mar 2017, 06:01

Can't setup Gear S3 Classic

Postby 0908727527 » 30 Jun 2017, 06:47

Can't setup Gear S3C with Mi 6/5S, rooted/unrooted

Samsung Gear app pairs fine with the watch, however it crashes shortly after "Setting up" appears on the phone.
I've tried numerous times from scratch, cleared cache/data, reinstalled app, nothing helps and Samsung support so far came with nothing.

Details :
"The first i installed the Gear App, app finded the watch but after click to connect button it displayes the popupp message "Download filed. Try again." I checked the Gear app all permissions, all of them is "Accept".

I tried pair with Stable ROM/Dev ROM from en.miui.com. The Gear app informed, that need install S plugin and Samsung Accessory Service. Gear app worked very well.

So, i tried manually install to my Mi6/5s the needed software too.
I downloaded app, plugin and "Samsung Accessory Service". The app find the watch, but when i try to connect. It has some error and app is close. "Unfortunately, Samsung Gear has stopped."

Maybe i did something wrong? Please help me! Thanks!!!

Return to “Support and Help”

Who is online

Users browsing this forum: TheBlueFX and 18 guests

Gearbest Consumer Electric Promotion promotion